Skip to Content

بلاگ

پروتکل ISL انحصاری شرکت سیسکو

پروتکل ISL انحصاری شرکت سیسکو

یکی ازروش هایی که سیسکو برای عملیات Tagging در اتصالات Trunk مورد استفاده قرار می دهد روش پروتکل ISL است. این روش در محیط های Ethernet و نیز Ring Token مورد استفاده قرار می گیرد.اما به دلیل اینکه امروز استفاده از Token Ring محدود شده است، این روش فقط در محیط های Ethernet بکار می رود.

بجز چند استثنا تمامی سوئیچ ها و روتر های سیسکو که از Trunking پشتیبانی می کنند،قابلیت استفاده از ISL را نیز دارا هستند.سوئیچ های قدیمی تری مثل۴۰۰۰ Catalyst فقط ازروش ۸۰۲٫۱ Q استفاده می کنن.برای چنین سوئیچ هایی ،Interface های موجود در روی آنها باید توانایی ارسال و دریافت اطلاعات با سرعت حداقل ۱۰۰ مگابات بر ثانیه را داشته باشد.

این Interface ها شامل Fast Ethernet و Gigabit Ethernet می شوند. علاوه بر این سوئیچ ها باید دارای ASIC های مخصوصی برای انجام عملیات Tagging نیز باشند. در یاد داشته باشید که برخی از Interface هایی که از Fast Ethernet استفاده می کنند، ممکن است از ISL پشتیبانی نکنند. بنابراین قبل از خرید سوئیچ ها و روتر ها همیشه از امکانات دستگاه و پشتیبانی آنها از اتصالات Trunk آگاهی لازم را کسب نمائید.

قسمت بالای شکل زیر مثالی از  پروتکل ISL را نشان می دهد.

پروتکل ISL فریم اصلی Ethernet را بوسیله افزودن ۲۶ بایت به اول و ۴ بایت به آخر فریم اصلاح کرده، و بنابراین فریم اصلی در بین Header و Trailer آن قرار خواهد گرفت.

با توجه به اینکه حداکثر اندازه فریم Ethernet برابر با ۱۵۱۸ بایت می باشد. با افزوده شدن ۳۰ بایت توسط ISL به فریم Ethernet اندازه آن از مقدار استاندارد بیشتر شده و بنابراین دستگاه هایی که دارای کارت شبکه استاندارد هستند، این فریم را یک فریم Giant (یعنی بزرگتر از استاندارد ) تشخیص داده و فریم را از بین می برند. حتی اگر اندازه فریم بزرگتر از ۱۵۱۸ بایت هم نشود،باز هم کارت های شبکه استاندارد،قادر به پردازش Header و Trailer افزوده شده نخواهند بود.

حالا مفهوم این حرف را که در اتصالات نوع Access link ،سوئیچ ها برای ارسال اطلاعات همیشه Header و Trailer را حذف کرده و سپس اقدام به ارسال فریم ها می کنند درک می کنید.سوئیچ ۱۹۰۰ فقط از پروتکل ISL وسوئیچ ۲۹۵۰ فقط از Q1. 802 پشتیبانی می کنند . در جدول زیر قسمت های مختلف Header مربوط به ISL شرح داده شده اند..

Destination MAC Adrdress: DA : نشان دهنده آدرس MAC دستگاه گیرنده پیام می باشد.

Type : نشان دهنده نوع فریم انکپسوله شده میباشد . مانند Eternet و ATM و Token Ring و FDDI

User : نشان دهنده میزان اولویت Priority مربوط به فریم میباشد.

SA : Source MAC Address : شامل آدرس MAC دستگاه فرستنده میباشد.

Length : سایز کلی فرم ISL که شامل قسمت Header و قسمت Trailer و فریم انکپسوله شده میباشد را بیان مینماید.

SNAP : اگر فریم ISL حاوی این فیلد باشد نشان دهنده این است که این فریم از نوع IEEE SNAP 2.802LLC میباشد.

VLAN Identifier : این فیلد شامل ۱۵ بیت بوده که ۱۰ بیت آن نشان دهنده شماره VLAN مورد استفاده میباشد با این تعداد بیت میتوان حداکثر ۱۰۲۴ عدد VLAN را شماره گذاری نمود.

BPDU : این فیلد در صورت وجود نشان دهنده این است که فریم مزبور از نوع BPDU STP و یا CDP میباشد.

Index : شامل شماره پورت میگردد

Reserved : این قسمت یک فیلد رزرو شده بوده و در حال حاضر استفاده نمیگردد

ادامه مطلب

پروتکل OSPF

پروتکل OSPF

پروتکل OSPF :پروتکل مسیریابی OSPF پروتکل قدرتمند و پرطرفداری است که در RFC 2328 شرح داده شده است. این پروتکل برای پیدا کردن Neighbor یا در واقع روترهای متصل به خود  از Hello Message استفاده میکند. پیام Hello به آدرس Multicast 224.0.0.5)AllSPFRouters) ارسال میگردد اگر در رسانه ای خاص Multicast قابل استفاده نباشد، از Unicast استفاده میکند (در این حالت آدرس همسایه باید از قبل تنظیم شده باشد).

آشنایی با پروتکل OSPF

پروتکل مسیریابی Open Shortest Path First که به اختصار OSPF نامیده می شود یک پروتکل مسیریابی Link state است که میتواند ترافیک های مربوط به پروتکل IP را مدیریت کند. پروتکل OSPF نسخه های مختلفی دارد که در حال حاضر از نسخه ۲ آن بیشتراستفاده می شود.OSPF بصورت انحصاری توسط شرکت ها ارائه میشوند و یک پروتکل کاملا جامع و بدون وابستگی به هیچ برند خاصی است ، تقریبا همه روترهایی که در دنیا وجود دارند از پروتکل OSPF پشتیبانی می کنند.

پروتکل مسیریابی Open Shortest Path First یا پروتکل OSPF از الگوریتم Shortest Path First یا SPF که توسط Dijkstra طراحی شده است برای جلوگیری از به وجود آمدن Routing Loop در توپولوژی شبکه ها استفاده می کند و به نوع یک شبکه Loop Free ایجاد می کند. پروتکل OSPF فرآیند Convergence سریعی دارد و از طرفی قابلیت Incremental Update را نیز با استفاده ازLSA یا Link State Advertisement فراهم می کند. پروتکل مسیریابی OSPF یک پروتکل Classless است و به شما این اجازه را می دهد که برای طراحی یک ساختار سلسله مراتبی شبکه از VLSM و Route Summarization به راحتی استفاده کنید.

معرفی پروتکل OSPF

معرفی پروتکل OSPF

معایب پروتکل OSPF

مهمترین معایبی که در پروتکل OSPF وجود دارد این است که OSPF برای نگهداری لیست OSPF Neighbor ها ، توپوپولوژی شبکه که شامل یک دیتابیس از تمامی روترها و Route های موجود در آنهاست و همچنین Routing Table خود روتر به حافظه RAM نسبتا بیشتری در مقایسه با پروتکل های Distance Vector نیاز دارد.همچنین پروتکل OSPF به قدرت پردازشی یا CPU بیشتری برای اجرا کردن الگوریتم SPF نیاز دارد و همین موارد باعث می شود که OSPF در رده بندی پروتکل های مسیریابی پیچیده یا Complex Protocol قرار بگیرد. دو مفهوم بسیار مهم در مواردی که می خواهید از پروتکل OSPF استفاده کنید وجود دارند که اولین مفهوم Autonomous System و دومین مفهوم Area می باشد.

تنظیمات اولیه در OSPF

Area در OSPF برای ایجادکردن ساختارمسیریابی سلسله مراتبی یا موثری(Hierarchical Routing)در یک Autonomous System استفاده میشود. Area ها تعیین کننده این هستندکه چگونه وبه چه اندازه اطلاعات مربوط بهRoutingبایستی درشبکه به اشتراک گذاشته شود. OSPF دولایه وراثت یاHierarchyدارد،لایهBackboneیاArea 0 ولایه های خارج ازBackboneیاAreaهای بین عدد۱تا۶۵۵۳۵،این دوAreaای متفاوت هستندکه میتوان دربین آنهااطلاعات مسیریابی راSummarizeکرد. RouteSummarizationبه ما کمک میکندکه بتوانیم Routing Tableهای خودرافشرده سازی وکوچکترکنیم.تمامی Areaها بایستی بهArea 0متصل شوندوتمامی روترهادراینAreaازیک توپولوژی یکسان استفاده میکنند.

 

 

 

ادامه مطلب

کارت ویپ VOIP سیسکو VIC2-4FXO

کارت ویپ VOIP سیسکو VIC2-4FXO

ماژول‌های شبکه دیجیتال بر مبنای صدا و فکس، عضو اصلی ارتباطات با کیفیت هستند که توسط کمپانی سیسکو سیستم طراحی و تولید شده است. ارتباطات در بستر IP با سرعت بالا، انتقال صدا و فکس به صورت دیجیتال و با کیفیت بالا، اتصال WAN با تراکم بالا، اتصال صوتی به شکل آنالوگ، کنفرانس تلفنی و قابلیت رمزگذاری، در یک ماژول یا کارت ویپ قابل ارائه است.

ماژول‌های شبکه، سازمان‌ها و شرکت‌های ارائه دهنده خدمات را قادر می‌سازد تا به طور مستقیم به شبکه تلفن سراسری یا PSTN که سرواژه عبارت Public Switched Telephone Network است؛ متصل شوند. همچنین امکان اتصال به تجهیزات تلفنی قدیمی مانند PBX از جمله تلفن‌های آنالوگ و دستگاه‌های فکس نیز میسر خواهد بود.

روترهای سیسکو سازگار با کارت ویپ VOIP

برای استفاده از قابلیت‌های ارتباط در بستر IP می‌توان از روترهای سیسکو 2811، 2821، 2851، 2911، 2921، 2951، 3825، 3845، 3925 و 3945 استفاده کرد. ماژول‌های شبکه با استفاده از این فناوری، با روترهای سیسکو به صورت یکپارچه ارتباط برقرار کرده و راه حل مناسبی برای ارتباط از ظریق بستر IP هستند.

فناوری ارتباطی سیسکو IP به معنای ادغام صدا و داده است. کاربران می‌توانند از خدماتی مانند تلفن‌های IP، سرویس‌های یکپارچه و پرداخت تلفنی استفاده کنند. این راه حل‌ها به شرکت‌ها و ارائه دهندگان خدمات شبکه اجازه می‌دهد تا از مزایای ارتباطات Unified مانند هزینه‌های عملیاتی پایین و افزایش راندمان بهره‌مند شوند. راهکارهای ارتباطی یکپارچه سیسکو شامل تکنولوژی‌های صوتی بسته مانندVoIP و از جمله H.323، پروتکل دروازه رسانه یا MGCP و پروتکل سیپ یا SIP می‌شود.

ارتباطات IP با کیفیت بالا به صورت دیجیتال صدا و فکس بخشی جداناپذیر از ارتباطات یکپارچه سیسکو است. ارائه یک ترکیب چند منظوره از صدای دیجیتال، صدای آنالوگ و قابلیت‌های دیتا در فرم فاکتور واحد شبکه را هموار خواهد کرد.
این فناوری‌ها نه تنها دسترسی گیت‌وی IP Phone را به معماری Cisco UC برای تماس با PSTN و WAN فراهم می‌کند؛ بلکه اجازه می‌دهد تا شرکت‌ها تا زمانی که آماده مهاجرت به تلفن IP نیستند، با استفاده از تجهیزات تلفن سنتی موجود، شبکه را مستقر کنند.

امکانات کارت ویپ VOIP سیسکو

شرکت‌ها می‌توانند تمامی این ویژگی‌ها را با یک ماژول یا کارت ویپ VOIP مستقر کنند و امکان اتصال به PSTN، تجهیزات تلفن سنتی مانند PBX ها، تلفن‌های آنالوگ، دستگاه‌های فکس و ارتباط WAN فراهم آورند. انواع کارت‌ها یا VIC های مختلف از قبیل FXS با 2 پورت، DID، FXO، E&M،FXS با 4 پورت، FXO با 4 پورت و BRI با 2 پورت توسط روترهای سیسکو پشتیبانی می‌شوند.

این کارت‌ها تمام اتصالات آنالوگ را در کنار اتصالات دیجیتال BRI هم در سمت کاربر و هم سمت شبکه پوشش می‌دهد. به طور مثال کارت ویپ VOIP مورد بحث در این مقاله یعنی VIC2-4FXO به عنوان رابط صدا و فکس عمل می‌کند و در سیستم مخابراتی تمام کشورها قابل استفاده است. این کارت همچنین از CAMA آنالوگ با هر نوع پورتی پشتیبانی خواهد کرد.

مفهوم FXS و FXO

FXS و FXO دو اصطلاح پرکاربرد در سیستمهای IPPBX و VoIP به ویژه در زمینه کار با خطوط آنالوگ است. FXO سرواژه عبارت Foreign Exchange Office یا در واقع درگاهی است که برق یا به عبارتی سیگنال بوق را دریافت می‌کند. از این درگاه برای اتصال خطوط آنالوگ مخابرات یعنی PSTNبه سیستم‌های تلفنی مبتنی IP استفاده می‌شود. برای ارتباط با خطوط شهری مخابرات به درگاه FXO نیاز خواهد بود.

FXS سرواژه عبارت Foreign Exchange Station است. به این معنی که درگاهی برای تولید برق یا به عبارتی تولید سیگنال بوق است. از این درگاه برای اتصال تلفن‌های معمولی غیر از IP Phone به سیستم استفاده می‌شود. با استفاده از این درگاه می‌توان داخلی‌های شرکت را بر روی گوشی تلفن‌ها عادی نیز راه‌اندازی کرد.

پورت FXO برای اتصال به PBX یا برای فراهم کردن اتصالات به PSTN یا PTT استفاده می‌شود. همچنین از تعویض باتری و سیستم شناسایی تماس گیرنده نیز پشتیبانی می‌کند. کارت‌های ویپ VOIP مانند VIC2-4FXO می‌تواند به صورت نرم‌افزاری برای فعالیت در سیستم مخابراتی هر کشوری پیکربندی شوند. همچنین برای اتصال به ترانک CAMA آنالوگ برای ارائه سرویس اختصاصیE-911 البته فقط در آمریکای شمالی استفاده می‌شود.

ادامه مطلب

نصب و راه اندازی تلفن IP Phone سیسکو 7962G و 7942G

نصب و راه اندازی تلفن IP Phone سیسکو 7962G و 7942G

در این مقاله و مقاله‌ی آتی در مورد چگونگی استفاده از IP Phone سیسکو مدل 7962G و تلفن 7942G صحبت خواهیم کرد. ابتدا به اجزای مختلف این دو تلفن می‌پردازیم و سپس امکانات و ویژگی‌های مختلف آن را بررسی می‌کنیم.

Cisco Unified IP Phone 7962G 7942G تلفن سیسکو سوئیچ شبکه

 

۱. خط تلفن و شماره‌گیری سریع: باز کردن خط جدید، شماره‌گیری سریع و قطع تماس. آی پی فون سیسکو 7962G تعداد ۶ خط تلفن و ۶ کلید شماره‌گیری سریع را ارایه می‌دهد. مدل سیسکو 7942G از ۲ خط تلفن و ۲ کلید شماره‌گیری سریع پشتیبانی می‌کند.

۲. صفحه نمایش: نشان دهنده ساعت، تاریخ، شماره تلفن، شماره تماس گیرنده، وضعیت خطوط، لیبل کلیدهای عملگر و سایر محتویات گرافیکی است.

۳. تنظیم پایه: امکان تنظیم زاویه تلفن نسبت به پایه را برای کاربر فراهم می‌کند.

۴. کلید پیام‌ها: دسترسی به صندوق پست صوتی

۵. تاریخچه تماس: دسترسی به تاریخچه تماس‌های ارسالی و دریافتی

۶. راهنما: نمایش راهنمای تنظیمات و کلیدها در صفحه نمایش

۷. تنظیمات: برای تنظیمات سفارشی کاربر نظیر صدای زنگ و کنتراست صفحه نمایش استفاده می‌شود.

۸. خدمات: کلید خدمات برای برنامه‌های کاربردی

۹. بلندی صدا: تنظیم کردن بلندی صدا برای اسپیکر، گوشی و هدست و کنترل بلندی صدا در هنگام idle بودن تلفن

۱۰. اسپیکر: فعال کردن اسپیکر

۱۱. قطع تماس: قطع صدای تماس

۱۲. هدست: انتقال صدای تماس بین گوشی و اسپیکر

۱۳. کلید ناوبری: انتخاب و ناوبری در گزینه‌های صفحه نمایش یا تماس‌های ورودی

۱۴. صفحه شماره‌گیری: کلیدهای شماره‌گیری تماس

۱۵. کلیدهای عملگر: لیبل کلیدهای عملگر در بالای آن‌ها و پایین صفحه نمایش نوشته شده است. هرکدام از کلید در وضعیت‌های مختلف، عملکرد متفاوتی خواهند داشت.

۱۶. گوشی با نشانگر LED: نشانگر LED بر روی گوشی،‌ هنگام زنگ خوردن چشمک می‌زند. در صورت دریافت پیغام صوتی نیز روشن می‌شود.

راهنمای نصب و راه اندازی تلفن IP Phone سیسکو 7962G و 7942G

شماره گیری

برای گرفتن شماره تلفن مورد نظر می‌توانید یکی از روش‌های زیر را انتخاب کنید:

  • گوشی را بردارید و شماره مورد نظر را بگیرید.
  • بدون برداشتن گوشی، کلید NewCall را فشار دهید و شماره‌گیری کنید. پس از برقراری ارتباط، گوشی را بردارید. برای صحبت از طریق اسپیکر، گوشی را برندارید.
  • بدون برداشتن گوشی، شماره را بگیرید و کلید Dial را فشار دهید. از اسپیکربرای تماس استفاده می‌شود.
  • کلید Speaker را فشار دهید و شماره مورد نظر را بگیرید.
  • برای تکرار تماس از کلید Redial استفاده کنید.

قرار دادن تماس در حالت انتظار

کلید Hold را فشار دهید. دکمه خط به رنگ زرد تغییر می‌کند. برای بازگشت به تماس کلید Resume را انتخاب کنید.

نکته: مکالمه‌ی در حالت انتظار بدون این‌که دو طرف صدای هم را بشنوند، فعال باقی می‌ماند. همچنین در این حالت می‌توانید یک تماس دیگر نیز برقرار کنید.

تنظیم حجم صدا

از کلیدهای + یا – برای افزایش یا کاهش بلندی صدا استفاده کنید. برای ذخیره تغییرات،کلید Save را فشار دهید.

قطع صدا

برای قطع کردن میکروفون در طول تماس، کلید MUTE را فشار دهید. اگر در حالت اسپیکر هستید، می‌توانید گوشی را بر روی دستگاه قرار دهید. در این صورت قادر به شنیدن تماس هستید، اما صدای شما منتقل نمی‌شود. برای برقراری مجدد صدا، کلیدMUTE را بزنید و گوشی را بردارید.

کار با صفحه نمایش

برای کنترل مکان‌نما، کلید << را فشار دهید. از کلید >> برای پاک کردن یک کاراکتر یا شماره استفاده کنید. برای انتخاب یک آیتم از منو دکمه ی ناوبری را فشار دهید. کلید Select را فشار دهید. یا کلید شماره مورد نظر را مطابق با شماره آیتم منو در صفحه شماره‌گیری انتخاب کنید.

نکته: کار کردن با گزینه‌های مختلف صفحه نمایش بسیار آسان است. از کلید ناوبری، کلید های عملگر و صفحه کلید برای انتخاب آیتم‌ها استفاده کنید. برای خروج از یک منو در صفحه LCD تلفن، کلیدExit را فشار دهید.

تنظیم کنتراست صفحه نمایش

برای تنظیم نور صفحه نمایش، کلید Settings را فشار دهید و گزینه User Preferences را انتخاب کنید. از منوی مربوطه، Contrast را برگزینید. سپس برای تنظیم کنتراست دلخواه، کلید های بالا یا پایین را فشار دهید. در نهایت برای ذخیره کردن تغییرات، کلید Save را فشار دهید.

ادامه مطلب

مفهوم NAT و انواع آن

مفهوم NAT و انواع آن

هنگام استفاده از آدرس های IPv4 یکی از موارد مهم و حساس در استفاده از آنها، فضای آدرس دهی کم و محدود می باشد. با توجه به اینکه دستگاه هایی که به اینترنت متصل می شوند و نیاز به آدرس آی پی دارند و روز به روز درحال افزایش هستند، باید در روند استفاده از آنها محتاط تر عمل کرد. با توجه به این مسئله از روشی به نام NAT استفاده شد که بتوان با استفاده از آن سازمان شبکه های داخلی خودشان را با آدرس های خصوصی، آدرس دهی کنند و در صورت نیاز به دسترسی به اینترنت، از یک آدرس عمومی استفاده نمایند.

نحوه عملکرد NAT

نحوه عملکرد NAT

 

برای مثال در شکل بالا، شبکه داخلی از محدوده آدرس های خصوصی برای شبکه داخلی استفاده کرده است، اما روتری که شبکه سازمان را به اینترنت متصل می کند دارای یک آدرس عمومی میباشد که اگر کلاینت ها درخواستی به سمت اینترنت ارسال کنند، روتر آدرس آنها را به آدرس عمومی خودش ترجمه کرده و سپس به سمت اینترنت ارسال می کند. به عبارت دیگر در اینجا با استفاده از یک آدرس عمومی می توان تعداد بسیار زیادی آدرس خصوصی را به اینترنت متصل کرد. این کار باعث صرفه جویی در مصرف آدرس های IP خواهد شد.

موارد استفاده از NAT :

زمانی که کلاینت های سازمانی برای برقراری ارتباط با اینترنت نیاز به آدرس عمومی نداشته باشند.

زمانی که قصد داشته باشید تا بدون ایجاد تغییر در ساختار آدرس دهی داخلی، ISP خود را تغییر دهید.

زمانی که نیاز به برقراری ارتباط بین دو شبکه اینترانت که دارای آدرس های یکسان هستند دارید.

NAT همانند هر تکنولوژی دیگر که دارای مزایا می باشد، یکسری معایب نیز دارد که در ادامه به بررسی این دو جنبه میپردازیم.

مزایای NAT:

  • استفاده از آدرس های عمومی را کم می کند.
  • راه حلی برای برقراری ارتباط بین محدوده آدرس های یکسان است.
  • ارائه راه حلی آسان جهت برقراری با اینترنت.
  • عدم نیاز به تغییر آدرس های درونی، در هنگام تغییر ISP.

معایب NAT:

  • عملیات ترجمه آدرس باعث افزایش تاخیر در روند سوئیچینگ می شود.
  • باعث می شود تا نودهای شبکه ارتباط مستقیم با یکدیگر نداشته باشند.
  • بعضی از برنامه ها از NAT پشتیبانی نمیکنند.

انواع NAT

به صورت کلی NAT به سه شکل قابل پیاده سازی می باشد که شامل:

NAT از نوع ایستا:

در این حالت عملیات تبدیل آدرس عمومی به خصوصی یک به یک است، به این معنی که شما باید به ازای هر آدرس خصوصی یک آدرس عمومی را در دسترس داشته باشید.

NAT از نوع پویا:

در این حالت یک استخر از آدرس های عمومی وجود دارد که اگر یکی از کلاینت ها قصد ارسال داده به سمت اینترنت داشته باشد، روتر یک آدرس را به صورت پویا به کلاینت اختصاص خواهد داد. به بیان دیگر شیوه عملکرد این نوع از NAT همانند ایستا بوده با این تفاوت که دیگر مدیر شبکه نیازی به تخصیص آدرس عمومی به خصوصی ندارد. توجه داشته باشید که همانند حالت قبل باید به ازای تمامی آدرس های خصوصی، آدرس عمومی وجود داشته باشد.

NAT از نوع Overloading:

به بیان ساده، این نوع از NAT همانند پویا بوده با این تفاوت که میتوان چندین آدرس خصوصی را با استفاده از یک آدرس عمومی به اینترنت متصل نمود. این شیوه از NAT بسیار محبوب و پر استفاده می باشد. با استفاده از این نمونه NAT می توان تا هزاران کامپیوتر را به اینترنت متصل نمود و همین مسئله باعث شده است تا استفاده از آدرس های عمومی تا حد زیادی مدیرت شده و بهینه باشد.

حال که با انواع NAT آشنا شدید بهتر است تا با چند واژه مهم در NAT آشنا شوید که آشنایی با آنها کمک شایانی به درک این مسئله به شما خواهد کرد.

نام های مورد استفاده در NAT

در هنگام استفاده از NAT چهار واژه اصلی مورد استفاده قرار میگیرد که آنها را در قالب چند شکل مورد بررسی قرار خواهیم داد.

Inside Local:

این دسته از آدرس ها، همان آدرس های محلی بوده که در شبکه خصوصی مورد استفاده قرار می گیرد و در هدر بسته ثبت شده است.

Outside Local:

این آدرس نشان دهنده مقصد بسته می باشد که در هدر بسته ثبت شده است.

Inside Global:

آدرسی است که بعد از انجام عملیات ترجمه در قسمت مبدا بسته قرار داده می شود.

توجه داشته باشید که تمام درخواست های ارسال شده توسط کلاینت دارای پورت هایی منحصر به فرد می باشد. از این رو روتر با استفاده از آدرس IP خودش و پورتی منحصر به فرد که برای کلاینت درنظر می گیرد خواهد توانست عملیات ترجمه را انجام دهد.

Outside Global:

این همان آدرس مقصد است که کلاینت درخواست های خود را برای آنها ارسال می کند.

 

NAT از نوع ایستا

همان گونه که در قسمت قبل اشاره کردیم، این نوع از NAT توسط مدیر شبکه انجام می شود و باید به ازای تک تک آدرس های خصوصی که قصد برقراری ارتباط با اینترنت را دارند، یک آدرس عمومی در اختیار داشته باشید. شیوه کار کرد این NAT در مراحل زیر توضیح داده شده است.

۱- ابتدا مدیر شبکه باید آدرس های IP عمومی در دسترس را به آدرس های خصوصی اختصاص دهد.

۲- یک رنج ۱۶تایی از آدرس IP در دسترس میباشد. مدیر

باتوجه به نیازهای خودش این آدرس ها را به کلاینت ها اختصاص میدهد.

برای مثال فرض کنید که مدیر آدرس ها را به صورت زیر تعریف کرده است.

آدرس عمومی آدرس خصوصی
۷۸.۴۷.۵۰.۴۹ ۱۹۲.۱۶۸.۱.۱۱
۷۸.۴۷.۵۰.۵۰ ۱۹۲.۱۶۸.۱.۱۰

۳- حال در صورتی که آدرس ۱۹۲.۱۶۸.۱.۱۱ قصد برقراری ارتباط با اینترنت را داشته باشد، ابتدا آدرس مبدا آن توسط روتر به ۷۸.۴۷.۵۰.۴۹ تغییر کرده و سپس پکت ها به سمت اینترنت روانه میشوند.

NAT از نوع پویا

در این نوع از NAT تنها کاری که مدیر شبکه باید انجام دهد، این است که لیستی از آدرس های عمومی را برای روتر مشخص کنند تا این آدرسها به صورت خودکار به کلاینت هایی که قصد برقراری ارتباط با اینترنت را دارند اختصاص داده شود.

هر درخواستی که برای روتر ارسال شود اولین آدرس عمومی که آزاد میباشد و توسط کامپیوتر دیگری اشغال نشده است، انتخاب شده و به کلاینت اختصاص داده می شود.

مراحل این نوع از NAT به صورت زیر است:

۱- در ابتدای کار مدیر باید لیستی از آدرس های عمومی را در روتر تعریف کند.

۲- درهنگامی که یک کلاینت به منظور برقراری ارتباط با اینترنت، درخواست خود را به سمت روتر ارسال می کند، اولین آدرس آزاد به کلاینت اختصاص داده خواهد شد و تا زمانی که کلاینت ارتباط خودش را قطع نکند، IP برای آن رزرو خواهد ماند.

NAT از نوع Overload

این نوع NAT متفاوتتر از سایر روشها عمل میکند، در ادامه این روش را با جزئیات مورد بررسی قرار میدهیم.

۱- فرض کنید که روترتان دارای آدرس عمومی ۷۸.۴۷.۵۰.۴۹ است.

۲-در ادامه یک جدول تشکیل خواهد شد که در آن آدرس های Inside Local و Inside Global قرار دارد.

آدرس های Inside Global آدرس های Inside Local
۷۸.۴۷.۵۰.۴۹:۱۰۲۴ ۱۹۲.۱۶۸.۱.۱۱:۱۰۲۴
۷۸.۴۷.۵۰.۴۹:۱۰۲۵ ۱۹۲.۱۶۸.۱.۱۰:۱۰۲۵

نکته ای که در این جدول قابل مشاهده است، آدرس های پورت می باشد که با کمک آنها می توان جریان های داده چندین کلاینت را تنها با یک آدرس عمومی تبادل کرد.

در سطح تئوریک می توان تا ۶۵.۰۰۰ کلاینت را تنها با یک آدرس عمومی به اینترنت متصل نمود.

 

نام های مورد استفاده در NAT

نام های مورد استفاده در NAT

 

ادامه مطلب

پیاده سازی NAT

پیاده سازی NAT

در پست NAT چیست و انواع NAT قسمت اول و دوم با مفاهیم اولیه NAT آشنا شدید و مطالبی از قبیل انواع NAT ،NAT از نوع ایستا و پویا، NAT از نوع Overloading، نام های مورد استفاده در NAT و … را آموزش دادیم. در این مقاله قصد داریم موضوع پیاده سازی NAT  و عنوان هایی نظیر: پیاده سازی NAT از نوع ایستا و پویا و… مورد بررسی قرار دهیم.

NAT چیست و انواع NAT قسمت اول

NAT چیست و انواع NAT قسمت دوم

پیاده سازی NAT از نوع ایستا

در این تمرین میخواهیم دو کلاینت را با آدرس های ۵.۶.۷.۸  و  ۵.۶.۷.۹ به اینترنت متصل کنیم. توجه داشته باشید که برای اینکار قصد داریم از NAT استفاده کنیم.

مراحل تمرین

۱-ابتدا وارد روتر شوید به اینترفیس های آن آدرس آی پی اختصاص دهید.

 

RootLan(config)#interface fastEthernet 0/0

RootLan(config-if)#ip address 192.168.1.1 255.255.255.0

RootLan(config-if)#no shutdown

RootLan(config)#interface fastEthernet 0/1

RootLan(config-if)#ip address 5.6.7.7 255.255.255.255

RootLan(config-if)#no shutdown

۲-با استفاده از دستور زیر عملیات NAT را برای آدرس ۱۹۲.۱۶۸.۱.۱۱ انجام دهید.

RootLan(config)#ip nat inside source static 192.168.1.11 5.6.7.8

۳-با استفاده از دستور زیر عملیات NAT را برای آدرس ۱۹۲.۱۶۸.۱.۱۰ انجام دهید.

RootLan(config)#ip nat inside source static 192.168.1.10 5.6.7.9

۴-در ادامه باید جهت ترافیک ها را برای انجام NAT مشخص کنید. اینترفیس داخلی دارای ترافیک های ورودی و اینترفیس بیرونی دارای ترافیک خروجی است.

Zarrafe(config)#interface fastEthernet 0/0

Zarrafe(config-if)#ip nat inside

Zarrafe(config)#interface fastEthernet 0/1

Zarrafe(config-if)#ip nat outside

پیاده سازی NAT از نوع پویا

سازمانی دارای ۲۴۰ کاربر می باشد. این سازمان باید برای تمام کلاینت هایی که میخواهند با اینترنت ارتباط برقرار کنند از یک آدرس عمومی استفاده نمایند. برای این منظور یک رنج آدرس ۲۵۶ تایی برای سازمان تهیه شده است که برای استفاده کلاینت ها تهیه شده است.

مراحل تمرین

۱-وارد روتر R1 شده و سپس آدرس های آن را تنظیم کنید.

RootLan(config)#interface fastEthernet 0/0

RootLan(config-if)#ip address 192.168.1.1 255.255.255.0

RootLan(config-if)#no shutdown

RootLan(config)#interface fastEthernet 0/1

RootLan(config-if)#ip address 5.6.7.1 255.255.255.255

RootLan(config-if)#no shutdown

۲-ابتدا یک ACL از نوع استاندارد ایجاد کنید که در آن مشخص شده باشد کدام یک از آدرس های شبکه محلی مجاز به استفاده از NAT هستند.

RootLan(config)#access-list 1 permit 192.168.1.0 0.0.0.255

۳-در ادامه باید استخر آدرس های عمومی را به روتر معرفی نمایید. برای این منظور باید برای استخر آدرس ها یک نام درنظر بگیرید (در اینجا ما نام PublicIPs را درنظر گرفته ایم).

RootLan(config)#ip nat pool PublicIPs 5.6.7.2 5.6.7.254 netmask 255.255.255.0

۴-حال در ادامه باید ACL را به استخر آدرس ها اختصاص دهید.

RootLan(config)#ip nat inside source list 1 pool PublicIPs

۵-در نهایت باید NAT را برای اینترفیس های روتر مشخص کنید.

RootLan(config)#interface fastEthernet 0/0

RootLan(config-if)#ip nat inside

RootLan(config)#interface fastEthernet 0/1

RootLan(config-if)#ip nat outside

** نکته ی قابل توج این است که نام Pool به حروف کوچک و بزرگ حساس است.

ادامه مطلب

آموزش Boot کردن روتر های سیسکو

آموزش Boot کردن روتر های سیسکو

مراحل Boot کردن روتر های سیسکو و کاربرد برنامه Bootstrap
مراحل بوت شدن روتر های سیسکو را که به شرح زیر است باهم بررسی می کنیم.

  • روتر پروسه POST (که در رم قرار دارد) را بارگذاری و اجرا می‌کند (Post پروسه‌ای است که تمام سخت‌افزار روتر را بررسی می‌کند).
  • برنامه Bootstrap بارگذاری و اجرا می‌شود.
  • برنامه Bootstrap فایل IOS Image را پیدا و بارگذاری می‌کند (فایل IOS ممکن است برروی Flash یا سرور TFTP قرار داشته باشد).
  • زمانی که IOS بارگذاری شد، فایل Configuration File (که برروی NVRAM قرار دارد) را پیدا و بارگذاری می‌کند و درصورتی‌که فایل پیدا نشود سیستم‌عامل پروسه System Configuration Dialog را اجرا کرده تا تنظیمات ابتدایی روتر صورت پذیرد.
  • پس‌ازاین که فایل Configuration بارگذاری شد و یا پروسه System configuration Dialog به پایان رسید، محیط CLI نمایان می‌شود.

کاربرد برنامه Bootstrap

برای آشنایی با کاربرد برنامه Bootstrap ویژگی ها و تنظیمات آن را مرور می کنیم.

۱-مقدار رجیستر پیکربندی یا Configuration Register را بررسی می‌کند (این رجیستر از ۴ عدد مبنای ۱۶ تشکیل‌شده) و اگر رقم آخر این رجیستر بین ۲ تا F باشد روتر به مرحله ۲ می‌رود، در غیر این صورت:

  1. اگر مقدار ۰ باشد روتر در حالت ROMMON بوت خواهد شد.
  2. اگر مقدار ۱ باشد روتر را در حالت RXBOOT یا Min-IOS بوت خواهد شد.

۲-فایل پیکربندی درون NVRAM را چک می‌کند تا مقدار تنظیم‌شده برای دستور Boot System تشخیص داده و مکان فایل IOS Image را پیدا کند.

مقداری که برای دستور Boot system اختصاص داده‌شده است و به آدرس محل IOS Image در حافظه Flash اشاره میکند.

۳-درصورتی‌که دستور no boot system در فایل پیکربندی وجود داشته باشد اولین IOS Image معتبر در Flash بارگذاری خواهد شد.

۴-اگر IOS Image معتبری در Flash وجود نداشته باشد، یک درخواست Broadcast توسط دستگاه ارسال‌شده تا IOS Image از طریق سرور TFTP بارگذاری شود.

این پروسه Netboot نام دارد و در حالت عادی توصیه نمی‌شود چراکه این روش سرعت پایینی دارد.

سرور TFTP: سروری است که فایل‌هایی برروی آن وجود دارد و کلاینت‌ها می‌توانند فایل‌های موردنیازشان را از این سرور درخواست کنند.

۵-اگر سرور TFTP در دسترسی نباشد RXBOOT یا Min-IOS بارگذاری خواهد شد.

۶-اگر Min-IOS در ROM وجود داشته باشد، بارگذاری خواهد شد و در غیر این صورت سعی می‌کند IOS Image را پیدا و یا ROMMON را بارگذاری کند.

 Boot کردن روتر های سیسکو

با استفاده از دستورات زیر می‌توان فایل‌هایی که Bootstrap از آن‌ها استفاده می‌کند را تغییر داد.

bootstrp

bootstrp

❶ به‌جای پارامتر name_of_IOS_File_IN_Flash نام فایلی که در زمان بوت شدن، برنامه Bootstrap به دنبال آن می‌گردد را مشخص می‌کنید.

❷ به‌وسیله این دستور آدرس سرورTFTP و نام فایل IOS که در مرحله ۴ پروسه Bootstrap به دنبال آن می‌گردد را مشخص خواهید کرد.

نمایش حافظه‌های سیستم

با استفاده از دستور زیر، حافظه‌های دستگاه و ظرفیت آنها را مشاهده می‌کنید.

بوت استرپ

بوت استرپرجیستر پیکربندی یا Configuration Register

 

همان‌گونه که گفته شدبرنامه Bootstrap ازمقدارموجود دراین رجیستر محل بارگذاری فایل IOS Image و فایل پیکربندی را مشخص می‌کند.

برای دیدن مقدار این رجیستر می‌توانید از دستور Show Version استفاده کنید.

Show Version

Show Version

 

 

 

 

 

 

 

 

مراحل Boot کردن روتر های سیسکو

 

 

ادامه مطلب

راه اندازی IP Phone سیسکو

راه اندازی IP Phone سیسکو

چگونه یک تلفن سیسکو یا IP Phone سیسکو را راه اندازی کنیم؟ انجام این کار بسیار ساده است. در این مقاله، نحوه‌ی راه اندازی IP Phone سیسکو و مراحل و نکات اصلی آن را به اشتراک خواهیم گذاشت. با RootLan همراه باشید.

شکل زیر نمای کلی از روند راه اندازی یک تلفن یا همان IP Phone سیسکو را بازگو می کند. اگر از یک سوئیچ سیسکو با قابلیت PoE استفاده می‌کنید، کار ساده خواهد بود. کلمه PoE سرواژه عبارت Power over Ethernet است. برای راه اندازی تلفن سیسکو مراحل زیر را دنبال کنید.

IP Phone سیسکو تلفن سیسکو سوئیچ سیسکو پیکربندی vlan

مراحل راه اندازی IP Phone سیسکو

دریافت برق از سوئیچ: اگر سوئیچ سیسکو مورد نظر قادر به ارائه PoE باشد؛ یک سیگنال سریع پالس را که FLP نام دارد، ارسال می‌کند. این سوئیچ با استفاده از FLP تعیین می‌کند که آیا دستگاه متصل شده [در اینجا IP Phone سیسکو] غیرفعال است یا خیر.

بارگذاری حافظه ذخیره شده در تلفن: Phone IP سیسکو دارای مقداری حافظه فلش است که در آن نسخه‌ای از سیستم عامل و تنظیمات تعریف شده توسط کاربر ذخیره می‌شود. در هنگام راه اندازی، تلفن بوت استرپ را بارگذاری می‌کند که حاوی یک فایل ایمیج در حافظه فلش است. با استفاده از این Image نرم افزار و سخت افزار خود را اولویت بندی می‌کند.

پیکربندی VLAN: پس از دریافت برق و انرژی و روشن شدن تلفن، سوئیچ یک پکت Cisco Discovery Protocol را به Phone IP ارسال می‌کند. اگر این ویژگی پیکربندی شده باشد؛ پکت پروتکل کشف سیسکو، تلفن را با اطلاعات صوتی VLAN آماده به کار می‌کند.

دریافت آدرس IP و سرور TFTP: تلفن، درخواستی به سرور DHCP ارسال می‌کند. DHCP سرور با حداقل یک آدرس IP، یک Subnet Mask و آی پی TFTP به تلفن پاسخ می‌دهد. IP Phone نیز متعاقبا به TFTP سرور پاسخ می‌دهد. سرور TFTP دارای پرونده های پیکربندی با پسوندهای cnf یا xml است. از آن برای ارتباط با سایر تلفن‌ها استفاده می‌شود که شامل پارامترهایی برای اتصال به CallManager سیسکو کاربرد دارد.

سرور TFTP اطلاعات پیکربندی مربوط به آن IP Phone را ارسال می‌کند که حاوی لیست سفارش شده تا حداکثر سه CallManager است. به طور کلی، هر زمان که تغییری در Cisco CallManager انجام شود که به ریست گوشی نیاز باشد؛ تغییر در فایل پیکربندی آن تلفن ایجاد خواهد شد. اگر تلفن با XML سازگار باشد، فایل XMLDefault.cnf.xml را درخواست می‌کند. در غیر این صورت فایل cnf را درخواست خواهد کرد.

اگر ثبت خودکار را در CallManager سیسکو فعال کرده باشید، تلفن‌ها از یک پرونده پیش‌فرض تنظیمات با نام sepdefault.cnf.xml از سرور TFTP استفاده می‌کنند. اگر به صورت دستی تلفن‌ها را به دیتابیس CallManager سیسکو وارد کنید، Phone IP به فایل cnf.xml که به نام دستگاه شما مرتبط است دسترسی پیدا می‌کند. فایل cnf.xml همچنین حاوی اطلاعاتی است که به گوشی نشان می‌دهد کدام Image باید بارگیری شود. اگر این ایمیج با آن‌چه که در حال حاضر بر روی تلفن است، متفاوت باشد؛ دستگاه از سرور TFTP ایمیج جدید را درخواست می‌کند. این فایل باید با پسوند bin ذخیره شده باشد.

ثبت نام با CallManager سیسکو: پس از به دست آوردن پرونده از سرور TFTP، تلفن تلاش می‌کند تا یک اتصال TCP را به لیست تماس‌های مهم Cisco CallManager ایجاد کند.

ادامه مطلب

پروتکل های مسیریابی Classful و Classless

پروتکل های مسیریابی Classful vs Classless

پروتکل های مسیریابی را مي توان از لحاظ پارامترهاي مختلف در گروه هاي جداگانه قرار داد . يکي از تفاوت ها در Subnet mask مربوط به آدرس ها در داخل پيام هاي ارسالي مي باشد . بدين صورت که برخي از آن ها Subnet mask مربوطه را نيز در داخل پيام ارسالي گنجانده ولي برخي ديگر اين کار را نمي کنند . به ترتيب پروتکل هاي دسته اول را پروتکل Classless وپروتکل هاي دسته دوم راپروتکل Classful گويند .

زمانیکه نسبت به پروتکل های مسیریابی و الگوریتم های آنها شناخت پیدا می کنیم سوالی به ذهن همه ما خطور می کند که : از کدام پروتکل مسیریابی برای شبکه خود باید استفاده کنم ؟

در پاسخ به این سوال باید گفت که هیچگونه جواب مستقیم و قطعی برای آن وجود ندارد و در واقع معیار پاسخ به این سوال بررسی و ارزیابی فاکتورهای مشخصی می باشد . از نوع شبکه مورد استفاده ما تا تجهیزات آن و طراحی و بسیاری موارد دیگر . در نهایت شما با بررسی هایی که انجام می دهید اقدام به انتخاب یک پروتکل و الگوریتم مسیریابی نموده و شبکه خود را بوسیله آن راه اندازی می کنید .

بر مبنای آدرس دهی TCP/IP پروتکل های مسیریابی را می توان به دو دسته زیر تقسیم بندی نمود :

  1. پروتکل Classful
  2. پروتکل Classless

پروتکل Classful

به پروتکل هایی گفته می شود که هیچگونه اطلاعات مرتبط با Subnet mask را در بروزرسانی های مسیریابی خود حمل نکرده و جابجا نمی کنند . همچنین در این پروتکل ها برای برقراری ارتباط و تبادل بروزرسانی ها اینترفیس ها متقابل باید از Subnet Mask یکسانی برخوردار باشند . یکی از مسائل مرتبط با این پروتکل ها ارسال بروزرسانی ها بصورت دوره های زمانی مشخص برای تمامی اینترفیس ها می باشد حال آنکه چه بروزرسانی رخ داده باشد یا خیر . ارسال این بروزرسانی ها بصورت مداوم بخصوص بر روی لینک های WAN که از پهنای باند کمتری برخوردار هستند بالطبع باعث افزایش ترافیک و کندی سرعت خواهد شد . بطور کلی پروتکل مسیریابی Distance Vector را می توان جز پروتکل های Classful قرار داد . بعنوان مثال RIPV1 و IGRP از پروتکل های نوع ِClassful می باشند .

پروتکل Classless

این پروتکل ها برخلاف پروتکل های Classful هنگام انتقال بروزرسانی و تغییرات اطلاعات مرتبط با Subnet Mask را نیز منتقل می کنند . این نوع از پروتکل ها به شبکه اجازه می دهند تا از Subnet و طول های آدرس دهی مختلف استفاده کند ، از اینرو از CIDR و VLSM نیز پشتیبانی می کنند . تفاوت دیگر این پروتکل ها با نوع پروتکل های Classful ارسال نکردن بروزرسانی ها بصورت پریودیک می باشد .

مطلب دیگر تبادل جدول مسیریابی با همسایه های خود در زمانی هست که تغییری در جدول رخ داده باشد و درست در همین زمان است که اقدام به ارسال بروزرسانی نیز می کنند . بطور کلی در این نوع پروتکل ها زمانی که شبکه همگرا شد یکبار جدول مسیریابی مبادله می شود و مجددا تنها در صورتیکه تغییری در توپولوژی و آدرس های شبکه رخ دهد اقدام به ارسال بروزرسانی و جدول مسیریابی می کند .

اینکار کمک شایانی به مدیریت پهنای باند و اشغال نبودن آن خواهد کرد . تنها ارسال زمانبندی شده توسط پروتکل Classless ارسال Hello Packet در بازه های زمانی معین می باشد که آن هم برای تشخیص فعال بودن دستگاه مقابل است و این مطلب نیز پهنای باند زیادی را اشغال نخواهد کرد.

مشخصات کلي مربوط به اين گروه آدرس هاي IP

    • عمل Summarization در مرز بين شبکه ها بصورت خود به خود انجام مي گيرد .
    • عمليات Summarization در مورد route هايي که بين شبکه هاي ناشناخته منتقل مي شوند انجام شده و به صورت آدرس هاي با کلاس استاندارد در خواهند آمد .
    • پيام هايي که بين Subnetهاي يک شبکه کلاس استاندارد منتقل مي شوند،داراي ماسک مربوط به آدرس ها نيستند .
    • پروتکل Classful فرض را بر اين مي گيرند که Interfaceهاي مربوط به تمامي روترها به شبکه هايي با ماسک يکسان متصل گشته اند ودليل نگنجاندن ماسک مربوطه در داخل پيام هاي ارسالي نيز همين مسئله است .
    • شامل پروتکل هاي RIPv1 و IGRP مي باشد .

طرز هدايت پيام ها توسط پروتکل هاي Classful ،وابسته به قانون هاي مربوط به آنهاست.بدين صورت که اگر مورد متناظري در داخل جدول routing وجود داشته باشد،پيام دريافت شده به طرف همان مقصد هدايت خواهد شد . اگر هيچ مورد متناظري در داخل جدول وجود نداشته باشد ، پيام از بين خواهد رفت . حتي اگر از يک Default Route نيز استفاده شود ، تنها در صورتي استفاده از آن مجاز خواهد بود که هيچ نوع مورد متناظري در داخل جدول وجود نداشته باشد . بدين معني حتي در صورت وجود شبکه اصلي در داخل جدول route پيام ها از بين رفته و به سمت Default Route نيز ارسال نخواهند شد .

محدوديت هاي مربوط به اين دسته پروتکل ها

  1. پروتکل Classful باعث از دست رفتن آدرس هاي بيشتري مي شوند.
  2. استفاده از ويژگي VLSM در داخل شبکه مجاز نيست.
  3. بدون استفاده از VLSM اندازه جدول روتينگ بيش از حد نرمال افزايش يافته و بنابراين پيام هاي Update انتقالي بين روتر ها نيز داراي سايزي بزرگتر خواهند بود.

CLASSLESS ROUTING

پروتکل هاي فوق براي حل محدوديت هاي موجود در پروتکل هاي Classful مورد استفاده قرار مي گيرند .

مشخصات کلي اين دسته از آدرس هاي Ip

      • Interfaceهاي متصل به يک شبکه لايه سوم مي توانند از ماسک هاي متفاوتي استفاده نمايند.
      • شامل پروتکل هاي BGP،RIPV2،IS-IS،EIGRP،OSPF مي شوند.
      • استفاده از ويژگي CIDR در داخل شبکه مجاز مي باشد.
      • استفاده از هر نوع Stigmatization دستي و اتوماتيک در مورد Routeهاي موجود در جدول Routing مجاز مي باشد .

      براي اينکه پروتکل Classful نيز از برخي مزاياي موجود در پروتکل Classless برخوردار گردند، دستور IP CLASSLESS را مي توان اجرا نمود.البته بصورت Default،دستور مزبور در نسخه هاي اخير IOS فعال گشته است .

ادامه مطلب

آموزش SNMP در روتر و سوئیچ های سیسکو

آموزش SNMP در روتر و سوئیچ های سیسکو

آموزش SNMP در روتر و سوئیچ های سیسکو Simple Network Management Protocol یا همان SNMP پروتکل مشهور و پرکاربرد برای جمع‌آوری اطلاعات شبکه و مدیریت شبکه است. از SNMP برای جمع‌آوری اطلاعات مربوط به کانفیگ و تجهیزات شبکه مثل سرور، پرینتر، سوئیچ و روتر بر اساس یک IP، استفاده می‌شود. نکته دیگر این است که به ساختمان داده این پروتکل MIB یا Management Information Base می‌گویند.

دراین مقاله می‌خواهیم روش‌های کنترل دسترسی به SNMP را در سوئیچ سیسکو و روترهای این کمپانی بررسی کنیم.

معرفی SNMP

SNMP به طور پیش‌فرض از پورت‌های UDP 161 برای پیام‌های عمومی و از پورت UDP 162 برای پیام‌های trap استفاده می‌کند. متأسفانه در حال حاضر SNMP ورژن 1 به طور گسترده استفاده می‌شود که خیلی ایمن نیست. در این ورژن، اطلاعات به صورت Clear-text ارسال می‌شود و یکی از ضعف‌های اصلی آن است.

توصیه می‌شود اگر از سیستم‌های مانیتورینگ یا پروتکل SNMP استفاده نمی‌کنید؛ می‌توانید با دستورات زیر این سرویس را غیرفعال کنید:

Switch(config)# no snmp-server community
Switch(config)# no snmp-server enable traps
Switch(config)# no snmp-server system-shutdown
Switch(config)# no snmp-server

اگر سرویس SNMP را برای سوئیچ‌ها و روترهای داخل شبکه نیاز دارید؛ بهتر است از SNMP ورژن 3 استفاده کنید. این ورژن بسیار امن‌تر از ورژن 1 خواهد بود. ورژن 3 از یک رمزنگاری Hash برای احراز هویت و محافظت از Community String استفاده می‌کند. پیش از کار با دستورات این نسخه، بهتر است تنظیمات ورژن قدیم پاکسازی شود. دستوراتی که در پایین آورده شده است، نشان می‌دهد یک مدل امنیتی برای SNMP V3 چگونه ایجاد می‌شود.

Switch(config)# no access-list 12
Switch(config)# access-list 12 permit 172.30.100.2
Switch(config)# access-list 12 permit 172.30.100.3

تعریف گروه Admin با دسترسی خواندن و نوشتن MIB

Switch(config)# snmp-server group admins v3 auth read adminview write adminview

سپس یک کاربر به عنوان مثال root با یک کلمه عبور برای این گروه تعریف می‌کنیم. این پسوورد می‌تواند با MD5 هش شود. در انتهای دستور اکسس لیست 12 به این کاربر اعمال می‌کنیم:

Switch(config)# snmp-server user root admins v3 auth md5 MyP@ssw0rd access 12

سرانجام می‌توان مشخص کرد adminview به کدام قسمت‌های MIB دسترسی داشته باشد. در دستورات زیر دسترسی به شاخه‌های Internet از MIB وجود دارد. اما به شاخه‌هایی که آدرس‌های IP و اطلاعات مسیریابی را شامل می‌شود خیر.

Switch(config)# snmp-server view adminview internet included
Switch(config)# snmp-server view adminview ipAddrEntry excluded
Switch(config)# snmp-server view adminview ipRouteEntry excluded

اگر فقط snmp ورژن 1 بر روی سوئیچ یا روتر قابل دسترس است؛ با دستورات زیر و با یک اکسس لیست می‌توانیم دسترسی فقط خواندن را به یک سری IP ها اعمال کنیم.

Switch(config)# no access-list 12
Switch(config)# access-list 12 permit 172.30.100.2
Switch(config)# access-list 12 permit 172.30.100.3
Switch(config)# snmp-server community Hash-960301 ro 12

در انتها سرویس SNMP Trap برای مدیریت سوئیچ با دستورات زیر تنظیم می‌شود:

Switch(config)# snmp-server host 172.30.100.2 traps Hash-960301
Switch(config)# snmp-server host 172.30.100.3 traps Hash-960301
Switch(config)# snmp-server trap-source Loopback0
Switch(config)# snmp-server enable traps

آموزش SNMP در روتر و سوئیچ های سیسکو

ادامه مطلب